PDA

View Full Version : green monster



trog
12-14-2005, 05:29 PM
anyone have any trouble with one of these
mine, purchased in June, suddenly won't blow
thought if froze up but after bringing in house still won't make any noise

any suggestions would be appreciated
this whistle has not been used more than 4 days

Terry Roglitz

jeff t.
12-14-2005, 05:45 PM
anyone have any trouble with one of these
mine, purchased in June, suddenly won't blow
thought if froze up but after bringing in house still won't make any noise

any suggestions would be appreciated
this whistle has not been used more than 4 days

Terry Roglitz

When you say it won't blow, do you mean you can't get air through it, or do you mean that the air doesn't produce noise?

I've had a problem with the whistle (black piece) coming loose from the megaphone (green piece). If the whistle moves out of position inside the megaphone...it won't work.

I've superglued mine, but it came loose again so I plan to send it back to Dogs Afield.

trog
12-14-2005, 07:09 PM
When blowing through it - no noise comes out - has been in the house for 4 hours so freezing cannot be a problem

You would think that with no pea their could not be a problem - but I cannot make any noise with it.

Had been working and I had been using it with a hard of hearing dog which she responded to when she couldn't hear my voice in the airing yard.
Terry Roglitz

Howard N
12-14-2005, 08:40 PM
Terry, I'm on my 2nd one of these things now. I'd just about bet that you have it plugged up with foreign material of some sort. Have you tryed washing it out or running it through the dishwasher?