PDA

View Full Version : 3 1/2 shells and SBEII



2labs
01-23-2006, 03:41 PM
I recently purchased a new SBEII and the gun is jamming on ejecting the first 3 1/2 that is shot.
The shells are Federal.
Can anyone who has a SBEII tell me if they are having the same problem is so how did you fix it.
Dave.

Dave Combs
01-23-2006, 04:07 PM
Just a couple quick thoughts:

Is all the factory 'gunk' off of the action? Sometimes that heavy oil based sludge they store the guns in will gum up the action - especially in cold weather.

Is the recoil spring tube assembly clean? This has been a major issue with the Benelli's and many people have gone to the Sure Cycle stainless system.

Check empty hulls for expansion in the plastic or brass. Have seen the new action (on a supersport) jam when brass expanded after the shell was fired. I shoot Winchester Experts out of mine and have never had a problem, haven't shot federals to compare.

Check the barrel for residue that may be holding the shell when fired.

I've put CASES of shells through mine and have had it jam maybe 2-3 times. If it's none of the above you might call Benelli direct or your local dealer. www.benelliusa.com

RAB
01-23-2006, 05:34 PM
I had the same problem also. After i cleaned and removed all of the packing grease and gunk and gave it a LIGHT oiling it worked great. 8)

djansma
01-23-2006, 05:53 PM
one other thing to remember is to make sure the gun is up against your shoulder tight as it needs the recoil to cycle the shell all the way I have sbe 11 and a sbe and that is the only time I have had trouble is with quick shots and not all the way in tight to my shoulder
David

FOM
01-23-2006, 05:58 PM
I've also been told that you need to let the chamber close naturally versus holding and riding the bolt foward/closed.

FOM

Golddogs
01-23-2006, 06:56 PM
Is the recoil spring tube assembly clean? This has been a major issue with the Benelli's and many people have gone to the Sure Cycle stainless system.


Stainless is standard now to eliminate the rust up.

huntestaholic
01-25-2006, 02:27 AM
I do not know about the SBEII but I had 2 different SBE's and both of them jammed. i even sent one back to the factory and it still jammed. So I traded it on a browning gold and have not a minutes trouble and that was 3 years ago.

brucecaplin
02-08-2006, 04:16 PM
Federal Ammo always jams my old A-5. I believe it has something to do with the crimp expanding past the shell body when fired. Have u tried other ammo?

2labs
02-08-2006, 05:48 PM
Bruce,
I am going to try this next. It happened the last day of Goose season here, however it was the first time I had the new SBEII out for the day.
8 came in and 2 flew off between two guys. Not bad.
I guess I will take some 3.5 out for pigeon flyers and see if it is the ammo. thanks Dave.