PDA

View Full Version : xtrema 2 problem



Chad Westfall
01-25-2010, 11:32 AM
Has anyone had problems with their xtrema 2 cycling magnum 3.5's. I bought this gun new, ealier this year & probably shot about 200 rounds through it & have tried to keep it clean as manufacturers suggestions but my problems seem to come in very wet weather after I have shot several times that day. I have been shooting 3.5 magnums & they seem to have a good deal more build up/residue from the gases that they produce on the mag tube & I think my problems are starting there.

This is my first semi and I love it but sometimes when it don't cyle & the birds are in your face it's aggravating. I am used to a pump gun that you just have to "put in a little more elbow".

any suggestions would be great.

Jason Glavich
01-25-2010, 12:15 PM
I have had mine for 2 seasons. To be honest i shoot nothing but 3.5 and havent cleaned my gun yet this year, its been through alot of shooting and dunked in the water when i fell in, with 0 problems cycling, the only problem I have had was with rounds not firing which was with old rounds that sat out in the weather for a long period of time. I would take it to gunsmith its under warranty and see if they can find an issue.

J Fleming
01-25-2010, 02:53 PM
Chad,

I bought a brand new Extrema 2 this fall. Shot it a few times at skeet range before duck season, it did fine. Then duck season got here, and starting shooting 3.5's shells and it could not shoot but ONE and would hang up. I could feel some dragging on the reciever when i pulled it about halfway back, so i decided to take it apart and inspect. I found a welded pin or part on the back of the reciever that SHOULD have come from the factory flush with the receiver; however, it was NOT flush and was dragging just enough to keep 3.5's from cycling. I took a file and filed down the rough part of that pin on the back of the receiver, put the gun back together, and have shot about a case of 3.5's since then without any problems whatsoever.

Hope this helps!
Jason

P.S. If you don't understand where i am talking about looking on the back of the receiver, shoot me a PM and i can call you and walk you through it. I know how frustrated you are because i have been there.

caglatz
01-25-2010, 11:58 PM
No problem with the Xtrema 2 here - It's my most reliable shotgun. Shoots everything flawlessly. I would give yours a good cleaning - springs and everything. Make sure the parts fit together when you reassemble and shoot clean, dry shells. If it still fails to cycle send it back to Beretta to have them fix it.

Bobcanoes
01-27-2010, 05:23 PM
I have been using an Xtrema 2 for a few years and shoot 3.5 inch shell at geese in Canada and in state with no major issues. I would clean it good, make sure you go light on oil and try it again. If you still have issues Berretta will stand behind the gun.

Pupknuckle
01-28-2010, 06:30 AM
I have been shooting an extrema 2 since they came out about 4 or 5 years ago. I have had no problems with 2 3/4 thru 3 1/2 inch shells as long as they are fresh-not rusted. I hunt 40 to 50 days a year in a salt marsh.