PDA

View Full Version : Bumper boy new problem



Brokengunz
09-21-2012, 01:41 AM
Bumper boy receiver flashes like its charging, when I hit the launch button the power and low batt lights both flash. tried changing the battery and charging same result. Anyone solve this kind of problem ?

Sean Barbey
09-21-2012, 06:26 AM
I had a bad charger that did the same thing as you described.
Sean

Keith Stroyan
09-21-2012, 08:47 AM
Seems like your batteries aren't charged. Could be worn out batteries or a broken charger.

i found a good deal on new batteries here on RTF last winter. Do a search if it's batteries, those might still be available.

Brokengunz
09-21-2012, 10:07 AM
charging light flashes when I hook up the charger. I have 3 units and the transmitter, they all charge but the one unit. I tried switching the charge leads around in case of a broken wire, didn't help. I'm going to a HT this weekend, I'm going to charge everything, swap batteries and see if the unit works.
I ordered the upgrade a year ago and hate to put more $ into something I will be sending back (some day ? )

jollydog
09-22-2012, 10:13 AM
Had same problem. Called Bumper boy and they
Told me to charge one unit at a time.

Wayne Nutt
09-24-2012, 09:09 AM
Try charging the dead unit by itself. I had this problem once and this worked for me. After that it charged with multiple units on the charger. Don't know why this worked but BB told me to do it and it worked.

Brokengunz
09-24-2012, 12:13 PM
Thanks for all the replies .

Bumper Boy
09-24-2012, 04:57 PM
Thanks for all the replies .

Hi there Broken Gunz,

Easiest way to get a hold of us is always to call, or email support@bumperboy.com and call our number at 1-800-729-3822 ext 233 if you need help with Support. We can man the phones as best as possible, if we're on the lines, email is always fast to reach us too. Unfortunately we don't monitor this site as often as we do our support lines, so we couldn't help you with this, but do give us a call so we can handle anything you need.