The RetrieverTraining.Net Forums The Retriever Academy
Total Retriever Training with Mike Lardy
Hawkeye Media Gunners Up Tritronics Outdoor Media
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Bumper Boys

  1. #1
    Senior Member
    Join Date
    Feb 2003
    Location
    australia
    Posts
    283

    Default Bumper Boys

    Wonder if anyone can help. Less than 12 months ago I purchased a 4 shot to go with my two 2 shots. It has never really worked well and hardly been used. However circumstances are such that I want to use it regularly and the 4th bumper - furthest from the receiver wont work. The little arm goes backwards. Have tried two new servos and still does not work. Have sent email to Bumperboy but don't know how long they will take to reply. Sending the unit back to US is not really an option. Any ideas would be much appreciated!
    If you play their game train the way they train

  2. #2
    Senior Member Tom. P.'s Avatar
    Join Date
    Oct 2010
    Location
    N/W Indiana
    Posts
    290

    Default

    I can't really offer any help with your issues other than to say BB went out if business a few months back!. Many of us myself included have BB units in need of parts and or repair. BB was looking for someone possibly to buy the business. We are all waiting for some kind of resolution. Sorry I couldn't offer anything other to help You!

  3. #3
    Senior Member Clayton Evans's Avatar
    Join Date
    Jun 2008
    Location
    Cheney Wa.
    Posts
    219

    Default

    My best guess is that the wireing from the servo to the harness is backwards. Undo the connection, turn it over and plug it back in and see if thats it. Sounds like bumper boy screwed up the harness when it was put together.
    Clay
    Blue Skies Eye of the Storm MH
    Blue Skies Rags to Richs MH
    Blue Skies Travelin Man MH
    Blue Skies Snowy River Cruse SH
    Blue Skies Rough Rider Kate SH
    and all Chesapeake Bay Retrievers

  4. #4
    Member Mark AB's Avatar
    Join Date
    Oct 2010
    Location
    Central NY
    Posts
    70

    Default

    Not sure if I can help but I have been tinkering with my three units for awile now trying to keep them going. As Tom mentioned they are of of business and unless they find a buyer we will eventually have to find other remote options. You mention the arm on the servo goes backwards? Do you mean it flips in the wrong direction when you trip it with the transmitter? Is this something new or has it done this from the beginning? Have your tried changing the sequence order of the firing to see if its that specific launcher or something in the receiver causing the 4th shot to malfunction irrespective of order of shooting?
    Muck Madness Retrievers
    Mark Berger
    Chittenango, NY

    Emerald City Reba, SH
    Emerald City Rosie SH
    Muck Madness Hurricane ... "Cane"
    Muck Madness Bailey's Irish Cream ... Bailey

    www.muckmadnessretrievers.com

    "How you do anything is how you will do everything".

  5. #5
    Member Rusty Champion's Avatar
    Join Date
    Feb 2012
    Location
    Abbeville Alabama
    Posts
    42

    Default

    I've recently encountered this problem and I couldn't determine a complete fix, but I did put a bandaid on it. My last servo would swing the wrong way (instead of engaging the firing mechanism it would open the opposite direction) about half the time. There were several on here that suggested the connection from the wiring harness to the servo was crushed and didn't get a good connection. I didn't find that last connection to be damaged, but I believe it is the source of the problem. If it doesn't work, just wiggle that connection and it helps (this is my observation at least)
    Rusty Champion

    A Southern Night's Miller Light ~ Miller
    Abbey Creek's Southern Comfort ~ Abbey

    God Bless & War Eagle

  6. #6
    Member
    Join Date
    Jun 2012
    Location
    Gaylord, MI
    Posts
    48

    Default

    see the problem with bumper boy is that they want to get rich when they sell it. I contacted them a while back about it and more or less they didn't really want to sell it but license it to me for a fee. A very steep fee.Then they told me there was no money to be made in bumper boys the real money was in the hawks collar, and that it didn't make since to sell just the bumper boy line. Since everything is made overseas and only lightly assembled in the US you need to buy a large quantity at one time to make it cost effective. bottom line is i think this one may be gone for good.
    I have never understood why you can have the best trained dogs in the world, but when you put two dogs together the act like they have a half a brain between the both of them.


    Rkk's Lady Of the Lake

  7. #7
    Senior Member Brad B's Avatar
    Join Date
    Apr 2004
    Location
    Winnie, TX
    Posts
    1,657

    Default

    Newer servo on my 4 shooter does the same thing. Each time you trigger it, it backs up instead of launching. Worked great for about a month after I replaced the first servo. Now this. I was hoping that replacing the servo again would cure it but from the OP's description, sounds like I'm in the same boat headed up the same creek.

  8. #8
    Senior Member Tim West's Avatar
    Join Date
    May 2003
    Location
    Arcadia, OK
    Posts
    1,246

    Default

    I have a friend who has been a major player in the radio controlled airplane competitions. He has an old four shooter that I lost the transmitter on. He seems to think it will be fairly easy to make a control that will fire the launcher in sequence as well as trip the sound feature. I'll let you know when he comes up with something....
    www.duckclubofoklahoma.com
    www.arcadiaretrievers.com
    Home of:

    Bayou Magic's Rouxster Bleu "Bleu" Amateur Win
    Arcadia's Senor Jefe (Ret) 10 1/2 AA pts
    Co/owner FC/AFC Wing Magic's Louisiana Roux MH (Ret)
    AFC Arcadia's Say Goodnight Gracie (RIP)
    Arcadia's He's A Cracker "Archie" (RIP)

  9. #9
    Senior Member
    Join Date
    Jul 2007
    Location
    northern oklahoma
    Posts
    223

    Default

    Try the connection on the reciever mine was doing that and i press the connection in better and its working now.

  10. #10
    Senior Member Bruce MacPherson's Avatar
    Join Date
    Mar 2005
    Location
    Jewell, Ore
    Posts
    1,231

    Default

    Clay and Timm have the most probable fixes. I would suggest that the first thing to try would be the three prong plug going into the servo, Just unplug it , turn it over and plug it back in.
    "The longer you let a dog go in the wrong direction the more they think they are going in the right direction" Don Remien.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •