The RetrieverTraining.Net Forums The Retriever Academy
Total Retriever Training with Mike Lardy
Hawkeye Media Gunners Up Tritronics Gun Dog Broker
Results 1 to 6 of 6

Thread: Thunder Launcher ??'s

  1. #1
    Senior Member Chris Videtto's Avatar
    Join Date
    Nov 2010
    Location
    CT
    Posts
    873

    Default Thunder Launcher ??'s

    I used my new Thunder 5 shooter the other day. I set up per instructions and the first 5 shots went smooth. I reloaded by just putting bumpers back on the launcher and the launcher seemed to skip a couple shots....did not launch bumper but rotated to next one. This happened twice. I shut down the machine and restarted per instructions again and again it skipped 2 bumpers before launching. Any thoughts?

    Thanks in advance.

    Chris
    __________________________________________________ _____________

    Brownstone's Harley- "Harley" 7/29/2009 (By CH Woodhull's Roger That)
    Maple Hill's Ella Enchanted- "Ella" 8/30/2011 (By FC AFC Land Ahoy)

  2. #2
    Senior Member mitty's Avatar
    Join Date
    Dec 2010
    Location
    Salt Lake City
    Posts
    2,205

    Default

    Yes! That sounds familiar...my problem seemed to be that I let the gas flow too long before firing the second time.

    Here's the thread that helped me:

    http://www.retrievertraining.net/for...but-won-t-fire

    Good luck!
    Renee P

  3. #3
    Senior Member Waterdogs's Avatar
    Join Date
    Jan 2006
    Location
    Idaho-Oregon
    Posts
    503

    Default

    sound like the are like the Max 5000's.
    Faith consists in believing when it is beyond the power of reason to believe.

  4. #4
    Senior Member Steve Shaver's Avatar
    Join Date
    Jan 2003
    Location
    Cornish Utah
    Posts
    1,327

    Default

    Timing of just slightly call the m and they will tell you how to fix. pretty simple actually

  5. #5
    Senior Member Chris Videtto's Avatar
    Join Date
    Nov 2010
    Location
    CT
    Posts
    873

    Default

    Renee and Steve,

    Thanks for the info!

    Chris
    __________________________________________________ _____________

    Brownstone's Harley- "Harley" 7/29/2009 (By CH Woodhull's Roger That)
    Maple Hill's Ella Enchanted- "Ella" 8/30/2011 (By FC AFC Land Ahoy)

  6. #6
    Senior Member jd6400's Avatar
    Join Date
    Feb 2009
    Location
    NE OHio
    Posts
    834

    Default

    Quote Originally Posted by Steve Shaver View Post
    Timing of just slightly call the m and they will tell you how to fix. pretty simple actually
    Correct,Doug will run you through it and is pretty easy to fix.....very hard to describe in writing but will involve bending slightly the micro switch arm to make contact with the cam......hardest part will be removing cover screws ......theres a gazzilion.....Jim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •