RetrieverTraining.Net - the RTF banner

1 - 15 of 15 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter · #1 ·
I have a BB Derby Double that has work fine up until now but I had an issue with it last weekend. I think it must have to do with the transmitter signal. I stand next to the BB shoot and both bumpers work no problem. I back up to 150-200 yds and only one bumper shoots normally. The other one pops off like a dud. Anyone had this issue or have any advice?
 

·
Registered
Joined
·
226 Posts
Sounds to me like your o ring is shot. Either that or a bad blank.
 

·
Registered
Joined
·
7,657 Posts
A wet bumper can do it too.
 

·
Registered
Joined
·
100 Posts
If the servo is activated the problem is not with the transmitter, receiver wiring harness or servo. This is a unit in need of a cleaning/lube or "o" ring replacement. The only other thing i can think of is moisture/dud round. Good luck.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #5 ·
Def. not a bad primer. It has happened multiple times. What lube do I use? Also why will it work correctly when I stand close but not when I'm far away? Will try lube once I find out which one. Thanks!
 

·
Registered
Joined
·
7,271 Posts
Use plumbers grease on the o ring.
 

·
Registered
Joined
·
1,837 Posts
When I use Brown, I often get duds... Just seems to be a weak load for some reason, very inconsistant when I use them.
 

·
Registered
Joined
·
131 Posts
I also found the brown loads very unreliable .. Have been using green loads with no problems..Try using a spacer (pcv) on the barrel to adjust throw...
 

·
Registered
Joined
·
7,271 Posts
If they go to far you can put a pvc pipe sleeve on the barrel. Slide all the way down. Adjust the lenght of sleeve to the distance you want.
I use the yellow loads, made for launchers. The reds don't go far enough. I put 1 " length sleeves of 3/4" pvc on the barrels.
 

·
Registered
Joined
·
7,271 Posts
See my edit above.
 
1 - 15 of 15 Posts
Top